ALAS-2014-295


Amazon Linux AMI Security Advisory: ALAS-2014-295
Advisory Release Date: 2014-09-16 22:33 Pacific
Severity: Medium
References: CVE-2014-0015 

Issue Overview:

cURL and libcurl 7.10.6 through 7.34.0, when more than one authentication method is enabled, re-uses NTLM connections, which might allow context-dependent attackers to authenticate as other users via a request.


Affected Packages:

curl


Issue Correction:
Run yum update curl to update your system.

New Packages:
i686:
    curl-7.35.0-2.42.amzn1.i686
    libcurl-7.35.0-2.42.amzn1.i686
    libcurl-devel-7.35.0-2.42.amzn1.i686
    curl-debuginfo-7.35.0-2.42.amzn1.i686

src:
    curl-7.35.0-2.42.amzn1.src

x86_64:
    curl-7.35.0-2.42.amzn1.x86_64
    curl-debuginfo-7.35.0-2.42.amzn1.x86_64
    libcurl-devel-7.35.0-2.42.amzn1.x86_64
    libcurl-7.35.0-2.42.amzn1.x86_64