ALAS-2014-312


Amazon Linux AMI Security Advisory: ALAS-2014-312
Advisory Release Date: 2014-09-17 22:54 Pacific
Severity: Medium
References: CVE-2014-0050 

Issue Overview:

MultipartStream.java in Apache Commons FileUpload before 1.3.1, as used in Apache Tomcat, JBoss Web, and other products, allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted Content-Type header that bypasses a loop's intended exit conditions.


Affected Packages:

tomcat7


Issue Correction:
Run yum update tomcat7 to update your system.

New Packages:
noarch:
    tomcat7-docs-webapp-7.0.47-1.38.amzn1.noarch
    tomcat7-7.0.47-1.38.amzn1.noarch
    tomcat7-lib-7.0.47-1.38.amzn1.noarch
    tomcat7-webapps-7.0.47-1.38.amzn1.noarch
    tomcat7-el-2.2-api-7.0.47-1.38.amzn1.noarch
    tomcat7-javadoc-7.0.47-1.38.amzn1.noarch
    tomcat7-jsp-2.2-api-7.0.47-1.38.amzn1.noarch
    tomcat7-admin-webapps-7.0.47-1.38.amzn1.noarch
    tomcat7-servlet-3.0-api-7.0.47-1.38.amzn1.noarch

src:
    tomcat7-7.0.47-1.38.amzn1.src