ALAS-2014-318


Amazon Linux AMI Security Advisory: ALAS-2014-318
Advisory Release Date: 2014-09-18 00:07 Pacific
Severity: Medium
References: CVE-2014-0032 

Issue Overview:

A flaw was found in the way the mod_dav_svn module handled OPTIONS requests. A remote attacker with read access to an SVN repository served via HTTP could use this flaw to cause the httpd process that handled such a request to crash.

The get_resource function in repos.c in the mod_dav_svn module in Apache Subversion before 1.7.15 and 1.8.x before 1.8.6, when SVNListParentPath is enabled, allows remote attackers to cause a denial of service (crash) via vectors related to the server root and request methods other than GET, as demonstrated by the "svn ls http://svn.example.com" command.


Affected Packages:

subversion


Issue Correction:
Run yum update subversion to update your system.

New Packages:
i686:
    subversion-debuginfo-1.8.8-1.42.amzn1.i686
    subversion-devel-1.8.8-1.42.amzn1.i686
    subversion-python-1.8.8-1.42.amzn1.i686
    subversion-tools-1.8.8-1.42.amzn1.i686
    subversion-libs-1.8.8-1.42.amzn1.i686
    subversion-ruby-1.8.8-1.42.amzn1.i686
    subversion-perl-1.8.8-1.42.amzn1.i686
    subversion-javahl-1.8.8-1.42.amzn1.i686
    subversion-1.8.8-1.42.amzn1.i686
    mod_dav_svn-1.8.8-1.42.amzn1.i686

src:
    subversion-1.8.8-1.42.amzn1.src

x86_64:
    subversion-ruby-1.8.8-1.42.amzn1.x86_64
    subversion-javahl-1.8.8-1.42.amzn1.x86_64
    subversion-tools-1.8.8-1.42.amzn1.x86_64
    subversion-1.8.8-1.42.amzn1.x86_64
    subversion-perl-1.8.8-1.42.amzn1.x86_64
    subversion-libs-1.8.8-1.42.amzn1.x86_64
    subversion-devel-1.8.8-1.42.amzn1.x86_64
    mod_dav_svn-1.8.8-1.42.amzn1.x86_64
    subversion-debuginfo-1.8.8-1.42.amzn1.x86_64
    subversion-python-1.8.8-1.42.amzn1.x86_64