ALAS-2014-325


Amazon Linux AMI Security Advisory: ALAS-2014-325
Advisory Release Date: 2014-09-18 00:22 Pacific
Severity: Important

Issue Overview:

It was found that the secure processing feature of Xalan-Java had insufficient restrictions defined for certain properties and features. A remote attacker able to provide Extensible Stylesheet Language Transformations (XSLT) content to be processed by an application using Xalan-Java could use this flaw to bypass the intended constraints of the secure processing feature. Depending on the components available in the classpath, this could lead to arbitrary remote code execution in the context of the application server running the application that uses Xalan-Java. (CVE-2014-0107 )


Affected Packages:

xalan-j2


Issue Correction:
Run yum update xalan-j2 to update your system.

New Packages:
noarch:
    xalan-j2-demo-2.7.0-9.9.9.amzn1.noarch
    xalan-j2-javadoc-2.7.0-9.9.9.amzn1.noarch
    xalan-j2-2.7.0-9.9.9.amzn1.noarch
    xalan-j2-manual-2.7.0-9.9.9.amzn1.noarch
    xalan-j2-xsltc-2.7.0-9.9.9.amzn1.noarch

src:
    xalan-j2-2.7.0-9.9.9.amzn1.src