ALAS-2014-336


Amazon Linux AMI Security Advisory: ALAS-2014-336
Advisory Release Date: 2014-09-18 00:34 Pacific
Severity: Medium

Issue Overview:

A buffer overflow flaw was found in the way ImageMagick handled PSD images that use RLE encoding. An attacker could create a malicious PSD image file that, when opened in ImageMagick, would cause ImageMagick to crash or, potentially, execute arbitrary code with the privileges of the user running ImageMagick.

A buffer overflow flaw affecting ImageMagick when creating PSD images was reported. The vulnerability is similar to CVE-2014-1947 , except that CVE-2014-2030 's format string is "L%06ld" instead of CVE-2014-1947 's "L%02ld" due to commit r1448.


Affected Packages:

ImageMagick


Issue Correction:
Run yum update ImageMagick to update your system.

New Packages:
i686:
    ImageMagick-6.7.8.9-10.15.amzn1.i686
    ImageMagick-c++-devel-6.7.8.9-10.15.amzn1.i686
    ImageMagick-devel-6.7.8.9-10.15.amzn1.i686
    ImageMagick-debuginfo-6.7.8.9-10.15.amzn1.i686
    ImageMagick-doc-6.7.8.9-10.15.amzn1.i686
    ImageMagick-c++-6.7.8.9-10.15.amzn1.i686
    ImageMagick-perl-6.7.8.9-10.15.amzn1.i686

src:
    ImageMagick-6.7.8.9-10.15.amzn1.src

x86_64:
    ImageMagick-c++-devel-6.7.8.9-10.15.amzn1.x86_64
    ImageMagick-debuginfo-6.7.8.9-10.15.amzn1.x86_64
    ImageMagick-devel-6.7.8.9-10.15.amzn1.x86_64
    ImageMagick-perl-6.7.8.9-10.15.amzn1.x86_64
    ImageMagick-doc-6.7.8.9-10.15.amzn1.x86_64
    ImageMagick-c++-6.7.8.9-10.15.amzn1.x86_64
    ImageMagick-6.7.8.9-10.15.amzn1.x86_64