ALAS-2014-345


Amazon Linux AMI Security Advisory: ALAS-2014-345
Advisory Release Date: 2014-09-18 00:36 Pacific
Severity: Medium
References: CVE-2014-0172 

Issue Overview:

Integer overflow in the check_section function in dwarf_begin_elf.c in the libdw library, as used in elfutils 0.153 and possibly through 0.158 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a malformed compressed debug section in an ELF file, which triggers a heap-based buffer overflow.


Affected Packages:

elfutils


Issue Correction:
Run yum update elfutils to update your system.

New Packages:
i686:
    elfutils-devel-static-0.158-3.16.amzn1.i686
    elfutils-libelf-0.158-3.16.amzn1.i686
    elfutils-devel-0.158-3.16.amzn1.i686
    elfutils-debuginfo-0.158-3.16.amzn1.i686
    elfutils-libs-0.158-3.16.amzn1.i686
    elfutils-0.158-3.16.amzn1.i686
    elfutils-libelf-devel-0.158-3.16.amzn1.i686
    elfutils-libelf-devel-static-0.158-3.16.amzn1.i686

src:
    elfutils-0.158-3.16.amzn1.src

x86_64:
    elfutils-debuginfo-0.158-3.16.amzn1.x86_64
    elfutils-devel-0.158-3.16.amzn1.x86_64
    elfutils-libelf-0.158-3.16.amzn1.x86_64
    elfutils-libelf-devel-0.158-3.16.amzn1.x86_64
    elfutils-libelf-devel-static-0.158-3.16.amzn1.x86_64
    elfutils-0.158-3.16.amzn1.x86_64
    elfutils-devel-static-0.158-3.16.amzn1.x86_64
    elfutils-libs-0.158-3.16.amzn1.x86_64