ALAS-2014-346


Amazon Linux AMI Security Advisory: ALAS-2014-346
Advisory Release Date: 2014-09-18 00:37 Pacific
Severity: Medium

Issue Overview:

Multiple directory traversal vulnerabilities in (1) mod_evhost and (2) mod_simple_vhost in lighttpd before 1.4.35 allow remote attackers to read arbitrary files via a .. (dot dot) in the host name, related to request_check_hostname.

SQL injection vulnerability in mod_mysql_vhost.c in lighttpd before 1.4.35 allows remote attackers to execute arbitrary SQL commands via the host name, related to request_check_hostname.


Affected Packages:

lighttpd


Issue Correction:
Run yum update lighttpd to update your system.

New Packages:
i686:
    lighttpd-mod_geoip-1.4.35-1.9.amzn1.i686
    lighttpd-fastcgi-1.4.35-1.9.amzn1.i686
    lighttpd-1.4.35-1.9.amzn1.i686
    lighttpd-debuginfo-1.4.35-1.9.amzn1.i686
    lighttpd-mod_mysql_vhost-1.4.35-1.9.amzn1.i686

src:
    lighttpd-1.4.35-1.9.amzn1.src

x86_64:
    lighttpd-mod_mysql_vhost-1.4.35-1.9.amzn1.x86_64
    lighttpd-debuginfo-1.4.35-1.9.amzn1.x86_64
    lighttpd-fastcgi-1.4.35-1.9.amzn1.x86_64
    lighttpd-mod_geoip-1.4.35-1.9.amzn1.x86_64
    lighttpd-1.4.35-1.9.amzn1.x86_64