ALAS-2014-357


Amazon Linux AMI Security Advisory: ALAS-2014-357
Advisory Release Date: 2014-09-19 10:23 Pacific
Severity: Low
References: CVE-2014-2524 

Issue Overview:

The _rl_tropen function in util.c in GNU readline before 6.3 patch 3 allows local users to create or overwrite arbitrary files via a symlink attack on a /var/tmp/rltrace.[PID] file.


Affected Packages:

readline


Issue Correction:
Run yum update readline to update your system.

New Packages:
i686:
    readline-debuginfo-6.2-9.14.amzn1.i686
    readline-6.2-9.14.amzn1.i686
    readline-devel-6.2-9.14.amzn1.i686
    readline-static-6.2-9.14.amzn1.i686

src:
    readline-6.2-9.14.amzn1.src

x86_64:
    readline-debuginfo-6.2-9.14.amzn1.x86_64
    readline-static-6.2-9.14.amzn1.x86_64
    readline-6.2-9.14.amzn1.x86_64
    readline-devel-6.2-9.14.amzn1.x86_64