ALAS-2014-385


Amazon Linux AMI Security Advisory: ALAS-2014-385
Advisory Release Date: 2014-09-19 11:38 Pacific
Severity: Critical
References: CVE-2014-1544 

Issue Overview:

Use-after-free vulnerability in the CERT_DestroyCertificate function in libnss3.so in Mozilla Network Security Services (NSS) 3.x, as used in Firefox before 31.0, Firefox ESR 24.x before 24.7, and Thunderbird before 24.7, allows remote attackers to execute arbitrary code via vectors that trigger certain improper removal of an NSSCertificate structure from a trust domain.


Affected Packages:

nss


Issue Correction:
Run yum update nss to update your system.

New Packages:
i686:
    nss-tools-3.16.0-1.36.amzn1.i686
    nss-devel-3.16.0-1.36.amzn1.i686
    nss-sysinit-3.16.0-1.36.amzn1.i686
    nss-debuginfo-3.16.0-1.36.amzn1.i686
    nss-3.16.0-1.36.amzn1.i686
    nss-pkcs11-devel-3.16.0-1.36.amzn1.i686

src:
    nss-3.16.0-1.36.amzn1.src

x86_64:
    nss-tools-3.16.0-1.36.amzn1.x86_64
    nss-debuginfo-3.16.0-1.36.amzn1.x86_64
    nss-sysinit-3.16.0-1.36.amzn1.x86_64
    nss-pkcs11-devel-3.16.0-1.36.amzn1.x86_64
    nss-3.16.0-1.36.amzn1.x86_64
    nss-devel-3.16.0-1.36.amzn1.x86_64