ALAS-2014-400


Amazon Linux AMI Security Advisory: ALAS-2014-400
Advisory Release Date: 2014-09-19 11:58 Pacific
Severity: Medium
References: CVE-2014-0475 

Issue Overview:

A directory traveral flaw was found in the way glibc loaded locale files. An attacker able to make an application use a specially crafted locale name value (for example, specified in an LC_* environment variable) could possibly use this flaw to execute arbitrary code with the privileges of that application.


Affected Packages:

glibc


Issue Correction:
Run yum update glibc to update your system.

New Packages:
i686:
    glibc-debuginfo-2.17-55.86.amzn1.i686
    glibc-2.17-55.86.amzn1.i686
    glibc-common-2.17-55.86.amzn1.i686
    glibc-devel-2.17-55.86.amzn1.i686
    glibc-utils-2.17-55.86.amzn1.i686
    glibc-static-2.17-55.86.amzn1.i686
    glibc-debuginfo-common-2.17-55.86.amzn1.i686
    nscd-2.17-55.86.amzn1.i686
    glibc-headers-2.17-55.86.amzn1.i686

src:
    glibc-2.17-55.86.amzn1.src

x86_64:
    glibc-common-2.17-55.86.amzn1.x86_64
    nscd-2.17-55.86.amzn1.x86_64
    glibc-static-2.17-55.86.amzn1.x86_64
    glibc-2.17-55.86.amzn1.x86_64
    glibc-devel-2.17-55.86.amzn1.x86_64
    glibc-debuginfo-2.17-55.86.amzn1.x86_64
    glibc-debuginfo-common-2.17-55.86.amzn1.x86_64
    glibc-utils-2.17-55.86.amzn1.x86_64
    glibc-headers-2.17-55.86.amzn1.x86_64