ALAS-2014-403


Amazon Linux AMI Security Advisory: ALAS-2014-403
Advisory Release Date: 2014-09-19 12:02 Pacific
Severity: Medium
References: CVE-2013-1982 

Issue Overview:

Multiple integer overflows in X.org libXext 1.3.1 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XcupGetReservedColormapEntries, (2) XcupStoreColors, (3) XdbeGetVisualInfo, (4) XeviGetVisualInfo, (5) XShapeGetRectangles, and (6) XSyncListSystemCounters functions.


Affected Packages:

libXext


Issue Correction:
Run yum update libXext to update your system.

New Packages:
i686:
    libXext-debuginfo-1.3.1-2.9.amzn1.i686
    libXext-devel-1.3.1-2.9.amzn1.i686
    libXext-1.3.1-2.9.amzn1.i686

src:
    libXext-1.3.1-2.9.amzn1.src

x86_64:
    libXext-debuginfo-1.3.1-2.9.amzn1.x86_64
    libXext-devel-1.3.1-2.9.amzn1.x86_64
    libXext-1.3.1-2.9.amzn1.x86_64