ALAS-2014-439


Amazon Linux AMI Security Advisory: ALAS-2014-439
Advisory Release Date: 2014-11-05 14:38 Pacific
Severity: Medium
References: CVE-2014-8080 

Issue Overview:

The REXML parser in Ruby 1.9.x before 1.9.3-p550, 2.0.x before 2.0.0-p594, and 2.1.x before 2.1.4 allows remote attackers to cause a denial of service (memory consumption) via a crafted XML document, aka an XML Entity Expansion (XEE) attack.


Affected Packages:

ruby21


Issue Correction:
Run yum update ruby21 to update your system.

New Packages:
i686:
    ruby21-libs-2.1.4-1.14.amzn1.i686
    rubygem21-bigdecimal-1.2.4-1.14.amzn1.i686
    ruby21-debuginfo-2.1.4-1.14.amzn1.i686
    rubygem21-io-console-0.4.2-1.14.amzn1.i686
    rubygem21-psych-2.0.5-1.14.amzn1.i686
    ruby21-2.1.4-1.14.amzn1.i686
    ruby21-devel-2.1.4-1.14.amzn1.i686

noarch:
    rubygems21-2.2.2-1.14.amzn1.noarch
    rubygems21-devel-2.2.2-1.14.amzn1.noarch
    ruby21-irb-2.1.4-1.14.amzn1.noarch
    ruby21-doc-2.1.4-1.14.amzn1.noarch

src:
    ruby21-2.1.4-1.14.amzn1.src

x86_64:
    ruby21-devel-2.1.4-1.14.amzn1.x86_64
    ruby21-2.1.4-1.14.amzn1.x86_64
    rubygem21-bigdecimal-1.2.4-1.14.amzn1.x86_64
    rubygem21-io-console-0.4.2-1.14.amzn1.x86_64
    rubygem21-psych-2.0.5-1.14.amzn1.x86_64
    ruby21-libs-2.1.4-1.14.amzn1.x86_64
    ruby21-debuginfo-2.1.4-1.14.amzn1.x86_64