ALAS-2014-444


Amazon Linux AMI Security Advisory: ALAS-2014-444
Advisory Release Date: 2014-11-11 10:33 Pacific
Severity: Medium

Issue Overview:

A denial of service flaw was found in libxml2, a library providing support to read, modify and write XML and HTML files. A remote attacker could provide a specially crafted XML file that, when processed by an application using libxml2, would lead to excessive CPU consumption (denial of service) based on excessive entity substitutions, even if entity substitution was disabled, which is the parser default behavior. (CVE-2014-3660 )


Affected Packages:

libxml2


Issue Correction:
Run yum update libxml2 to update your system.

New Packages:
i686:
    libxml2-2.9.1-3.1.32.amzn1.i686
    libxml2-python-2.9.1-3.1.32.amzn1.i686
    libxml2-devel-2.9.1-3.1.32.amzn1.i686
    libxml2-debuginfo-2.9.1-3.1.32.amzn1.i686
    libxml2-static-2.9.1-3.1.32.amzn1.i686

src:
    libxml2-2.9.1-3.1.32.amzn1.src

x86_64:
    libxml2-2.9.1-3.1.32.amzn1.x86_64
    libxml2-python-2.9.1-3.1.32.amzn1.x86_64
    libxml2-devel-2.9.1-3.1.32.amzn1.x86_64
    libxml2-static-2.9.1-3.1.32.amzn1.x86_64
    libxml2-debuginfo-2.9.1-3.1.32.amzn1.x86_64