ALAS-2014-448


Amazon Linux AMI Security Advisory: ALAS-2014-448
Advisory Release Date: 2014-11-16 13:32 Pacific
Severity: Medium
References: CVE-2014-8090 

Issue Overview:

The upstream patch for CVE-2014-8080 introduced checks against the REXML.entity_expansion_text_limit, but did not add restrictions to limit the number of expansions performed, i.e. checks against the REXML::Document.entity_expansion_limit. As a consequence, even with the patch applied, a small XML document could cause REXML to use an excessive amount of CPU time. High memory usage can be achieved using larger inputs.


Affected Packages:

ruby20


Issue Correction:
Run yum update ruby20 to update your system.

New Packages:
i686:
    ruby20-libs-2.0.0.598-1.20.amzn1.i686
    rubygem20-io-console-0.4.2-1.20.amzn1.i686
    ruby20-2.0.0.598-1.20.amzn1.i686
    rubygem20-psych-2.0.0-1.20.amzn1.i686
    ruby20-devel-2.0.0.598-1.20.amzn1.i686
    rubygem20-bigdecimal-1.2.0-1.20.amzn1.i686
    ruby20-debuginfo-2.0.0.598-1.20.amzn1.i686

noarch:
    rubygems20-2.0.14-1.20.amzn1.noarch
    ruby20-doc-2.0.0.598-1.20.amzn1.noarch
    ruby20-irb-2.0.0.598-1.20.amzn1.noarch
    rubygems20-devel-2.0.14-1.20.amzn1.noarch

src:
    ruby20-2.0.0.598-1.20.amzn1.src

x86_64:
    rubygem20-bigdecimal-1.2.0-1.20.amzn1.x86_64
    ruby20-libs-2.0.0.598-1.20.amzn1.x86_64
    rubygem20-psych-2.0.0-1.20.amzn1.x86_64
    ruby20-devel-2.0.0.598-1.20.amzn1.x86_64
    ruby20-2.0.0.598-1.20.amzn1.x86_64
    ruby20-debuginfo-2.0.0.598-1.20.amzn1.x86_64
    rubygem20-io-console-0.4.2-1.20.amzn1.x86_64