ALAS-2014-453


Amazon Linux AMI Security Advisory: ALAS-2014-453
Advisory Release Date: 2014-11-24 12:33 Pacific
Severity: Medium
References: CVE-2014-3710 

Issue Overview:

An out-of-bounds read flaw was found in the way the File Information (fileinfo) extension parsed Executable and Linkable Format (ELF) files. A remote attacker could use this flaw to crash a PHP application using fileinfo via a specially crafted ELF file.


Affected Packages:

file


Issue Correction:
Run yum update file to update your system.

New Packages:
i686:
    file-debuginfo-5.19-7.24.amzn1.i686
    file-5.19-7.24.amzn1.i686
    file-static-5.19-7.24.amzn1.i686
    file-libs-5.19-7.24.amzn1.i686
    file-devel-5.19-7.24.amzn1.i686

noarch:
    python-magic-5.19-7.24.amzn1.noarch

src:
    file-5.19-7.24.amzn1.src

x86_64:
    file-debuginfo-5.19-7.24.amzn1.x86_64
    file-devel-5.19-7.24.amzn1.x86_64
    file-static-5.19-7.24.amzn1.x86_64
    file-libs-5.19-7.24.amzn1.x86_64
    file-5.19-7.24.amzn1.x86_64