ALAS-2014-454


Amazon Linux AMI Security Advisory: ALAS-2014-454
Advisory Release Date: 2014-11-25 12:30 Pacific
Severity: Critical

Issue Overview:

Docker versions 1.3.0 through 1.3.1 allowed security options to be applied to images, allowing images to modify the default run profile of containers executing these images. This vulnerability could allow a malicious image creator to loosen the restrictions applied to a container's processes, potentially facilitating a break-out. (CVE-2014-6408 )

The Docker engine, up to and including version 1.3.1, was vulnerable to extracting files to arbitrary paths on the host during 'docker pull' and 'docker load' operations. This was caused by symlink and hardlink traversals present in Docker's image extraction. This vulnerability could be leveraged to perform remote code execution and privilege escalation. (CVE-2014-6407 )


Affected Packages:

docker


Issue Correction:
Run yum update docker to update your system.

New Packages:
src:
    docker-1.3.2-1.0.amzn1.src

x86_64:
    docker-1.3.2-1.0.amzn1.x86_64
    docker-pkg-devel-1.3.2-1.0.amzn1.x86_64
    docker-devel-1.3.2-1.0.amzn1.x86_64