ALAS-2015-463


Amazon Linux AMI Security Advisory: ALAS-2015-463
Advisory Release Date: 2015-01-08 11:43 Pacific
Severity: Medium
References: CVE-2014-8142 

Issue Overview:

Use-after-free vulnerability in the process_nested_data function in ext/standard/var_unserializer.re in PHP before 5.4.36, 5.5.x before 5.5.20, and 5.6.x before 5.6.4 allows remote attackers to execute arbitrary code via a crafted unserialize call that leverages improper handling of duplicate keys within the serialized properties of an object, a different vulnerability than CVE-2004-1019 .


Affected Packages:

php54


Issue Correction:
Run yum update php54 to update your system.

New Packages:
i686:
    php54-bcmath-5.4.36-1.64.amzn1.i686
    php54-odbc-5.4.36-1.64.amzn1.i686
    php54-pdo-5.4.36-1.64.amzn1.i686
    php54-mcrypt-5.4.36-1.64.amzn1.i686
    php54-pspell-5.4.36-1.64.amzn1.i686
    php54-snmp-5.4.36-1.64.amzn1.i686
    php54-xmlrpc-5.4.36-1.64.amzn1.i686
    php54-debuginfo-5.4.36-1.64.amzn1.i686
    php54-common-5.4.36-1.64.amzn1.i686
    php54-devel-5.4.36-1.64.amzn1.i686
    php54-mssql-5.4.36-1.64.amzn1.i686
    php54-embedded-5.4.36-1.64.amzn1.i686
    php54-mbstring-5.4.36-1.64.amzn1.i686
    php54-cli-5.4.36-1.64.amzn1.i686
    php54-soap-5.4.36-1.64.amzn1.i686
    php54-process-5.4.36-1.64.amzn1.i686
    php54-mysql-5.4.36-1.64.amzn1.i686
    php54-ldap-5.4.36-1.64.amzn1.i686
    php54-mysqlnd-5.4.36-1.64.amzn1.i686
    php54-tidy-5.4.36-1.64.amzn1.i686
    php54-5.4.36-1.64.amzn1.i686
    php54-gd-5.4.36-1.64.amzn1.i686
    php54-xml-5.4.36-1.64.amzn1.i686
    php54-pgsql-5.4.36-1.64.amzn1.i686
    php54-recode-5.4.36-1.64.amzn1.i686
    php54-intl-5.4.36-1.64.amzn1.i686
    php54-dba-5.4.36-1.64.amzn1.i686
    php54-enchant-5.4.36-1.64.amzn1.i686
    php54-imap-5.4.36-1.64.amzn1.i686
    php54-fpm-5.4.36-1.64.amzn1.i686

src:
    php54-5.4.36-1.64.amzn1.src

x86_64:
    php54-enchant-5.4.36-1.64.amzn1.x86_64
    php54-common-5.4.36-1.64.amzn1.x86_64
    php54-embedded-5.4.36-1.64.amzn1.x86_64
    php54-debuginfo-5.4.36-1.64.amzn1.x86_64
    php54-xmlrpc-5.4.36-1.64.amzn1.x86_64
    php54-process-5.4.36-1.64.amzn1.x86_64
    php54-gd-5.4.36-1.64.amzn1.x86_64
    php54-xml-5.4.36-1.64.amzn1.x86_64
    php54-pdo-5.4.36-1.64.amzn1.x86_64
    php54-5.4.36-1.64.amzn1.x86_64
    php54-intl-5.4.36-1.64.amzn1.x86_64
    php54-cli-5.4.36-1.64.amzn1.x86_64
    php54-odbc-5.4.36-1.64.amzn1.x86_64
    php54-mbstring-5.4.36-1.64.amzn1.x86_64
    php54-imap-5.4.36-1.64.amzn1.x86_64
    php54-mysql-5.4.36-1.64.amzn1.x86_64
    php54-snmp-5.4.36-1.64.amzn1.x86_64
    php54-pgsql-5.4.36-1.64.amzn1.x86_64
    php54-mcrypt-5.4.36-1.64.amzn1.x86_64
    php54-soap-5.4.36-1.64.amzn1.x86_64
    php54-mysqlnd-5.4.36-1.64.amzn1.x86_64
    php54-devel-5.4.36-1.64.amzn1.x86_64
    php54-tidy-5.4.36-1.64.amzn1.x86_64
    php54-pspell-5.4.36-1.64.amzn1.x86_64
    php54-mssql-5.4.36-1.64.amzn1.x86_64
    php54-bcmath-5.4.36-1.64.amzn1.x86_64
    php54-recode-5.4.36-1.64.amzn1.x86_64
    php54-fpm-5.4.36-1.64.amzn1.x86_64
    php54-ldap-5.4.36-1.64.amzn1.x86_64
    php54-dba-5.4.36-1.64.amzn1.x86_64