ALAS-2015-477


Amazon Linux AMI Security Advisory: ALAS-2015-477
Advisory Release Date: 2015-02-11 19:48 Pacific
Severity: Medium

Issue Overview:

The curl_easy_duphandle function in libcurl 7.17.1 through 7.38.0, when running with the CURLOPT_COPYPOSTFIELDS option, does not properly copy HTTP POST data for an easy handle, which triggers an out-of-bounds read that allows remote web servers to read sensitive memory information. (CVE-2014-3707 )

CRLF injection vulnerability in libcurl 6.0 through 7.x before 7.40.0, when using an HTTP proxy, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via CRLF sequences in a URL. (CVE-2014-8150 )


Affected Packages:

curl


Issue Correction:
Run yum update curl to update your system.

New Packages:
i686:
    curl-7.40.0-1.49.amzn1.i686
    libcurl-devel-7.40.0-1.49.amzn1.i686
    curl-debuginfo-7.40.0-1.49.amzn1.i686
    libcurl-7.40.0-1.49.amzn1.i686

src:
    curl-7.40.0-1.49.amzn1.src

x86_64:
    curl-7.40.0-1.49.amzn1.x86_64
    curl-debuginfo-7.40.0-1.49.amzn1.x86_64
    libcurl-devel-7.40.0-1.49.amzn1.x86_64
    libcurl-7.40.0-1.49.amzn1.x86_64