ALAS-2015-484


Amazon Linux AMI Security Advisory: ALAS-2015-484
Advisory Release Date: 2015-02-12 15:16 Pacific
Severity: Medium
References: CVE-2014-3248 

Issue Overview:

Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.


Affected Packages:

puppet


Issue Correction:
Run yum update puppet to update your system.

New Packages:
noarch:
    puppet-server-2.7.25-1.4.amzn1.noarch
    puppet-2.7.25-1.4.amzn1.noarch

src:
    puppet-2.7.25-1.4.amzn1.src