ALAS-2015-497


Amazon Linux AMI Security Advisory: ALAS-2015-497
Advisory Release Date: 2015-03-23 09:02 Pacific
Severity: Medium

Issue Overview:

The ELF parser in file 5.08 through 5.21 allows remote attackers to cause a denial of service via a large number of notes. (CVE-2014-9620 )

The ELF parser (readelf.c) in file before 5.21 allows remote attackers to cause a denial of service (CPU consumption or crash) via a large number of (1) program or (2) section headers or (3) invalid capabilities. (CVE-2014-8116 )

It was reported that a malformed elf file can cause file urility to access invalid memory. (CVE-2014-9653 )

The ELF parser in file 5.16 through 5.21 allows remote attackers to cause a denial of service via a long string. (CVE-2014-9621 )

softmagic.c in file before 5.21 does not properly limit recursion, which allows remote attackers to cause a denial of service (CPU consumption or crash) via unspecified vectors. (CVE-2014-8117 )


Affected Packages:

file


Issue Correction:
Run yum update file to update your system.

New Packages:
i686:
    file-debuginfo-5.22-2.29.amzn1.i686
    file-devel-5.22-2.29.amzn1.i686
    file-libs-5.22-2.29.amzn1.i686
    file-static-5.22-2.29.amzn1.i686
    file-5.22-2.29.amzn1.i686

noarch:
    python26-magic-5.22-2.29.amzn1.noarch
    python27-magic-5.22-2.29.amzn1.noarch

src:
    file-5.22-2.29.amzn1.src

x86_64:
    file-devel-5.22-2.29.amzn1.x86_64
    file-debuginfo-5.22-2.29.amzn1.x86_64
    file-5.22-2.29.amzn1.x86_64
    file-libs-5.22-2.29.amzn1.x86_64
    file-static-5.22-2.29.amzn1.x86_64