ALAS-2015-501


Amazon Linux AMI Security Advisory: ALAS-2015-501
Advisory Release Date: 2015-04-01 17:03 Pacific
Severity: Important

Issue Overview:

An information disclosure flaw was found in the way the 389 Directory Server stored information in the Changelog that is exposed via the 'cn=changelog' LDAP sub-tree. An unauthenticated user could in certain cases use this flaw to read data from the Changelog, which could include sensitive information such as plain-text passwords. (CVE-2014-8105 )

It was found that when the nsslapd-unhashed-pw-switch 389 Directory Server configuration option was set to "off", it did not prevent the writing of unhashed passwords into the Changelog. This could potentially allow an authenticated user able to access the Changelog to read sensitive information. (CVE-2014-8112 )


Affected Packages:

389-ds-base


Issue Correction:
Run yum update 389-ds-base to update your system.

New Packages:
i686:
    389-ds-base-debuginfo-1.3.2.27-1.27.amzn1.i686
    389-ds-base-devel-1.3.2.27-1.27.amzn1.i686
    389-ds-base-libs-1.3.2.27-1.27.amzn1.i686
    389-ds-base-1.3.2.27-1.27.amzn1.i686

src:
    389-ds-base-1.3.2.27-1.27.amzn1.src

x86_64:
    389-ds-base-devel-1.3.2.27-1.27.amzn1.x86_64
    389-ds-base-1.3.2.27-1.27.amzn1.x86_64
    389-ds-base-debuginfo-1.3.2.27-1.27.amzn1.x86_64
    389-ds-base-libs-1.3.2.27-1.27.amzn1.x86_64