ALAS-2015-506


Amazon Linux AMI Security Advisory: ALAS-2015-506
Advisory Release Date: 2015-04-15 22:21 Pacific
Severity: Important

Issue Overview:

A use-after-free flaw was found in the way PHP's unserialize() function processed data. If a remote attacker was able to pass crafted input to PHP's unserialize() function, they could cause the PHP interpreter to crash or, possibly, execute arbitrary code. (CVE-2015-0231 )

An integer overflow flaw, leading to a heap-based buffer overflow, was found in the way libzip, which is also embedded in PHP, processed certain ZIP archives. If an attacker were able to supply a specially crafted ZIP archive to an application using libzip, it could cause the application to crash or, possibly, execute arbitrary code. (CVE-2015-2331 )

Integer overflow in the regcomp implementation in the Henry Spencer BSD regex library (aka rxspencer) alpha3.8.g5 on 32-bit platforms, as used in NetBSD through 6.1.5 and other products, might allow context-dependent attackers to execute arbitrary code via a large regular expression that leads to a heap-based buffer overflow. (CVE-2015-2305 )


Affected Packages:

php54


Issue Correction:
Run yum update php54 to update your system.

New Packages:
i686:
    php54-xmlrpc-5.4.39-1.67.amzn1.i686
    php54-devel-5.4.39-1.67.amzn1.i686
    php54-pdo-5.4.39-1.67.amzn1.i686
    php54-5.4.39-1.67.amzn1.i686
    php54-mcrypt-5.4.39-1.67.amzn1.i686
    php54-fpm-5.4.39-1.67.amzn1.i686
    php54-pgsql-5.4.39-1.67.amzn1.i686
    php54-odbc-5.4.39-1.67.amzn1.i686
    php54-ldap-5.4.39-1.67.amzn1.i686
    php54-cli-5.4.39-1.67.amzn1.i686
    php54-mssql-5.4.39-1.67.amzn1.i686
    php54-debuginfo-5.4.39-1.67.amzn1.i686
    php54-process-5.4.39-1.67.amzn1.i686
    php54-intl-5.4.39-1.67.amzn1.i686
    php54-snmp-5.4.39-1.67.amzn1.i686
    php54-dba-5.4.39-1.67.amzn1.i686
    php54-mysqlnd-5.4.39-1.67.amzn1.i686
    php54-tidy-5.4.39-1.67.amzn1.i686
    php54-gd-5.4.39-1.67.amzn1.i686
    php54-embedded-5.4.39-1.67.amzn1.i686
    php54-pspell-5.4.39-1.67.amzn1.i686
    php54-recode-5.4.39-1.67.amzn1.i686
    php54-xml-5.4.39-1.67.amzn1.i686
    php54-mysql-5.4.39-1.67.amzn1.i686
    php54-imap-5.4.39-1.67.amzn1.i686
    php54-bcmath-5.4.39-1.67.amzn1.i686
    php54-common-5.4.39-1.67.amzn1.i686
    php54-mbstring-5.4.39-1.67.amzn1.i686
    php54-soap-5.4.39-1.67.amzn1.i686
    php54-enchant-5.4.39-1.67.amzn1.i686

src:
    php54-5.4.39-1.67.amzn1.src

x86_64:
    php54-mssql-5.4.39-1.67.amzn1.x86_64
    php54-mysqlnd-5.4.39-1.67.amzn1.x86_64
    php54-dba-5.4.39-1.67.amzn1.x86_64
    php54-odbc-5.4.39-1.67.amzn1.x86_64
    php54-imap-5.4.39-1.67.amzn1.x86_64
    php54-pspell-5.4.39-1.67.amzn1.x86_64
    php54-embedded-5.4.39-1.67.amzn1.x86_64
    php54-xmlrpc-5.4.39-1.67.amzn1.x86_64
    php54-debuginfo-5.4.39-1.67.amzn1.x86_64
    php54-fpm-5.4.39-1.67.amzn1.x86_64
    php54-tidy-5.4.39-1.67.amzn1.x86_64
    php54-recode-5.4.39-1.67.amzn1.x86_64
    php54-cli-5.4.39-1.67.amzn1.x86_64
    php54-5.4.39-1.67.amzn1.x86_64
    php54-ldap-5.4.39-1.67.amzn1.x86_64
    php54-xml-5.4.39-1.67.amzn1.x86_64
    php54-process-5.4.39-1.67.amzn1.x86_64
    php54-common-5.4.39-1.67.amzn1.x86_64
    php54-bcmath-5.4.39-1.67.amzn1.x86_64
    php54-snmp-5.4.39-1.67.amzn1.x86_64
    php54-gd-5.4.39-1.67.amzn1.x86_64
    php54-devel-5.4.39-1.67.amzn1.x86_64
    php54-mysql-5.4.39-1.67.amzn1.x86_64
    php54-mcrypt-5.4.39-1.67.amzn1.x86_64
    php54-pdo-5.4.39-1.67.amzn1.x86_64
    php54-enchant-5.4.39-1.67.amzn1.x86_64
    php54-soap-5.4.39-1.67.amzn1.x86_64
    php54-pgsql-5.4.39-1.67.amzn1.x86_64
    php54-intl-5.4.39-1.67.amzn1.x86_64
    php54-mbstring-5.4.39-1.67.amzn1.x86_64