ALAS-2015-528


Amazon Linux AMI Security Advisory: ALAS-2015-528
Advisory Release Date: 2015-05-27 15:00 Pacific
Severity: Low
References: CVE-2014-8964 

Issue Overview:

A flaw was found in the way PCRE handled certain malformed regular expressions. This issue could cause an application linked against PCRE to crash while parsing malicious regular expressions.


Affected Packages:

pcre


Issue Correction:
Run yum update pcre to update your system.

New Packages:
i686:
    pcre-devel-8.21-7.7.amzn1.i686
    pcre-debuginfo-8.21-7.7.amzn1.i686
    pcre-static-8.21-7.7.amzn1.i686
    pcre-tools-8.21-7.7.amzn1.i686
    pcre-8.21-7.7.amzn1.i686

src:
    pcre-8.21-7.7.amzn1.src

x86_64:
    pcre-static-8.21-7.7.amzn1.x86_64
    pcre-8.21-7.7.amzn1.x86_64
    pcre-debuginfo-8.21-7.7.amzn1.x86_64
    pcre-devel-8.21-7.7.amzn1.x86_64
    pcre-tools-8.21-7.7.amzn1.x86_64