ALAS-2015-529


Amazon Linux AMI Security Advisory: ALAS-2015-529
Advisory Release Date: 2015-05-27 15:22 Pacific
Severity: Medium
References: CVE-2015-1855 

Issue Overview:

As discussed in an upstream announcement, Ruby's OpenSSL extension suffers a vulnerability through overly permissive matching of hostnames, which can lead to similar bugs such as CVE-2014-1492 .


Affected Packages:

ruby18


Issue Correction:
Run yum update ruby18 to update your system.

New Packages:
i686:
    ruby18-static-1.8.7.374-2.42.4.amzn1.i686
    ruby18-libs-1.8.7.374-2.42.4.amzn1.i686
    ruby18-ri-1.8.7.374-2.42.4.amzn1.i686
    ruby18-debuginfo-1.8.7.374-2.42.4.amzn1.i686
    ruby18-devel-1.8.7.374-2.42.4.amzn1.i686
    ruby18-1.8.7.374-2.42.4.amzn1.i686

noarch:
    ruby18-irb-0.9.5-2.42.4.amzn1.noarch
    ruby18-rdoc-1.0.1-2.42.4.amzn1.noarch

src:
    ruby18-1.8.7.374-2.42.4.amzn1.src

x86_64:
    ruby18-debuginfo-1.8.7.374-2.42.4.amzn1.x86_64
    ruby18-static-1.8.7.374-2.42.4.amzn1.x86_64
    ruby18-1.8.7.374-2.42.4.amzn1.x86_64
    ruby18-devel-1.8.7.374-2.42.4.amzn1.x86_64
    ruby18-libs-1.8.7.374-2.42.4.amzn1.x86_64
    ruby18-ri-1.8.7.374-2.42.4.amzn1.x86_64