ALAS-2015-530


Amazon Linux AMI Security Advisory: ALAS-2015-530
Advisory Release Date: 2015-05-27 15:22 Pacific
Severity: Medium
References: CVE-2015-1855 

Issue Overview:

As discussed in an upstream announcement, Ruby's OpenSSL extension suffers a vulnerability through overly permissive matching of hostnames, which can lead to similar bugs such as CVE-2014-1492 .


Affected Packages:

ruby19


Issue Correction:
Run yum update ruby19 to update your system.

New Packages:
i686:
    rubygem19-json-1.5.5-32.66.amzn1.i686
    ruby19-debuginfo-1.9.3.551-32.66.amzn1.i686
    ruby19-libs-1.9.3.551-32.66.amzn1.i686
    rubygem19-bigdecimal-1.1.0-32.66.amzn1.i686
    ruby19-1.9.3.551-32.66.amzn1.i686
    ruby19-doc-1.9.3.551-32.66.amzn1.i686
    rubygem19-io-console-0.3-32.66.amzn1.i686
    ruby19-devel-1.9.3.551-32.66.amzn1.i686

noarch:
    rubygems19-devel-1.8.23.2-32.66.amzn1.noarch
    ruby19-irb-1.9.3.551-32.66.amzn1.noarch
    rubygems19-1.8.23.2-32.66.amzn1.noarch
    rubygem19-rdoc-3.9.5-32.66.amzn1.noarch
    rubygem19-minitest-2.5.1-32.66.amzn1.noarch
    rubygem19-rake-0.9.2.2-32.66.amzn1.noarch

src:
    ruby19-1.9.3.551-32.66.amzn1.src

x86_64:
    ruby19-1.9.3.551-32.66.amzn1.x86_64
    ruby19-debuginfo-1.9.3.551-32.66.amzn1.x86_64
    ruby19-doc-1.9.3.551-32.66.amzn1.x86_64
    ruby19-devel-1.9.3.551-32.66.amzn1.x86_64
    rubygem19-io-console-0.3-32.66.amzn1.x86_64
    rubygem19-bigdecimal-1.1.0-32.66.amzn1.x86_64
    ruby19-libs-1.9.3.551-32.66.amzn1.x86_64
    rubygem19-json-1.5.5-32.66.amzn1.x86_64