ALAS-2015-531


Amazon Linux AMI Security Advisory: ALAS-2015-531
Advisory Release Date: 2015-05-27 15:23 Pacific
Severity: Medium
References: CVE-2015-1855 

Issue Overview:

As discussed in an upstream announcement, Ruby's OpenSSL extension suffers a vulnerability through overly permissive matching of hostnames, which can lead to similar bugs such as CVE-2014-1492 .


Affected Packages:

ruby20


Issue Correction:
Run yum update ruby20 to update your system.

New Packages:
i686:
    rubygem20-bigdecimal-1.2.0-1.25.amzn1.i686
    rubygem20-psych-2.0.0-1.25.amzn1.i686
    ruby20-debuginfo-2.0.0.645-1.25.amzn1.i686
    ruby20-libs-2.0.0.645-1.25.amzn1.i686
    ruby20-devel-2.0.0.645-1.25.amzn1.i686
    rubygem20-io-console-0.4.2-1.25.amzn1.i686
    ruby20-2.0.0.645-1.25.amzn1.i686

noarch:
    ruby20-doc-2.0.0.645-1.25.amzn1.noarch
    ruby20-irb-2.0.0.645-1.25.amzn1.noarch
    rubygems20-2.0.14-1.25.amzn1.noarch
    rubygems20-devel-2.0.14-1.25.amzn1.noarch

src:
    ruby20-2.0.0.645-1.25.amzn1.src

x86_64:
    ruby20-debuginfo-2.0.0.645-1.25.amzn1.x86_64
    rubygem20-io-console-0.4.2-1.25.amzn1.x86_64
    ruby20-2.0.0.645-1.25.amzn1.x86_64
    rubygem20-bigdecimal-1.2.0-1.25.amzn1.x86_64
    ruby20-devel-2.0.0.645-1.25.amzn1.x86_64
    ruby20-libs-2.0.0.645-1.25.amzn1.x86_64
    rubygem20-psych-2.0.0-1.25.amzn1.x86_64