ALAS-2015-533


Amazon Linux AMI Security Advisory: ALAS-2015-533
Advisory Release Date: 2015-05-27 15:23 Pacific
Severity: Medium
References: CVE-2015-1855 

Issue Overview:

As discussed in an upstream announcement, Ruby's OpenSSL extension suffers a vulnerability through overly permissive matching of hostnames, which can lead to similar bugs such as CVE-2014-1492 .


Affected Packages:

ruby22


Issue Correction:
Run yum update ruby22 to update your system.

New Packages:
i686:
    ruby22-libs-2.2.2-1.5.amzn1.i686
    rubygem22-psych-2.0.8-1.5.amzn1.i686
    ruby22-2.2.2-1.5.amzn1.i686
    rubygem22-io-console-0.4.3-1.5.amzn1.i686
    ruby22-debuginfo-2.2.2-1.5.amzn1.i686
    ruby22-devel-2.2.2-1.5.amzn1.i686
    rubygem22-bigdecimal-1.2.6-1.5.amzn1.i686

noarch:
    rubygems22-devel-2.4.5-1.5.amzn1.noarch
    ruby22-doc-2.2.2-1.5.amzn1.noarch
    rubygems22-2.4.5-1.5.amzn1.noarch
    ruby22-irb-2.2.2-1.5.amzn1.noarch

src:
    ruby22-2.2.2-1.5.amzn1.src

x86_64:
    ruby22-libs-2.2.2-1.5.amzn1.x86_64
    ruby22-debuginfo-2.2.2-1.5.amzn1.x86_64
    ruby22-devel-2.2.2-1.5.amzn1.x86_64
    ruby22-2.2.2-1.5.amzn1.x86_64
    rubygem22-bigdecimal-1.2.6-1.5.amzn1.x86_64
    rubygem22-psych-2.0.8-1.5.amzn1.x86_64
    rubygem22-io-console-0.4.3-1.5.amzn1.x86_64