ALAS-2015-534


Amazon Linux AMI Security Advisory: ALAS-2015-534
Advisory Release Date: 2015-06-02 22:33 Pacific
Severity: Important

Issue Overview:

An integer underflow flaw leading to out-of-bounds memory access was found in the way PHP's Phar extension parsed Phar archives. A specially crafted archive could cause PHP to crash or, possibly, execute arbitrary code when opened. (CVE-2015-4021 )

An integer overflow flaw leading to a heap based buffer overflow was found in the way PHP's FTP extension parsed file listing FTP server responses. A malicious FTP server could use this flaw to cause a PHP application to crash or, possibly, execute arbitrary code. (CVE-2015-4022 )

A flaw was found in the way PHP parsed multipart HTTP POST requests. A specially crafted request could cause PHP to use an excessive amount of CPU time. (CVE-2015-4024 )

It was found that certain PHP functions did not properly handle file names containing a NULL character. A remote attacker could possibly use this flaw to make a PHP script access unexpected files and bypass intended file system access restrictions. (CVE-2015-4025 )

It was found that certain PHP functions did not properly handle file names containing a NULL character. A remote attacker could possibly use this flaw to make a PHP script access unexpected files and bypass intended file system access restrictions. (CVE-2015-4026 )

PCRE library is prone to a heap overflow vulnerability. Due to insufficient bounds checking inside compile_branch(), the heap memory could be overflowed via a crafted regular expression. Since PCRE library is widely used, this vulnerability should affect many applications using it. An attacker may exploit this issue to execute arbitrary code in the context of the user running the affected application. (CVE-2015-2325 )

PCRE library is prone to a vulnerability which leads to Heap overflow. Without enough bound checking inside pcre_compile2(), the heap memory could be overflowed via a crafted regular expression. Since PCRE library is widely used, this vulnerability should affect many applications. An attacker may exploit this issue to execute arbitrary code in the context of the user running the affected application. (CVE-2015-2326 )


Affected Packages:

php54


Issue Correction:
Run yum update php54 to update your system.

New Packages:
i686:
    php54-enchant-5.4.41-1.69.amzn1.i686
    php54-mssql-5.4.41-1.69.amzn1.i686
    php54-mbstring-5.4.41-1.69.amzn1.i686
    php54-pdo-5.4.41-1.69.amzn1.i686
    php54-gd-5.4.41-1.69.amzn1.i686
    php54-pgsql-5.4.41-1.69.amzn1.i686
    php54-mysql-5.4.41-1.69.amzn1.i686
    php54-odbc-5.4.41-1.69.amzn1.i686
    php54-soap-5.4.41-1.69.amzn1.i686
    php54-embedded-5.4.41-1.69.amzn1.i686
    php54-imap-5.4.41-1.69.amzn1.i686
    php54-bcmath-5.4.41-1.69.amzn1.i686
    php54-process-5.4.41-1.69.amzn1.i686
    php54-recode-5.4.41-1.69.amzn1.i686
    php54-mysqlnd-5.4.41-1.69.amzn1.i686
    php54-fpm-5.4.41-1.69.amzn1.i686
    php54-xmlrpc-5.4.41-1.69.amzn1.i686
    php54-mcrypt-5.4.41-1.69.amzn1.i686
    php54-snmp-5.4.41-1.69.amzn1.i686
    php54-tidy-5.4.41-1.69.amzn1.i686
    php54-cli-5.4.41-1.69.amzn1.i686
    php54-intl-5.4.41-1.69.amzn1.i686
    php54-dba-5.4.41-1.69.amzn1.i686
    php54-debuginfo-5.4.41-1.69.amzn1.i686
    php54-ldap-5.4.41-1.69.amzn1.i686
    php54-xml-5.4.41-1.69.amzn1.i686
    php54-pspell-5.4.41-1.69.amzn1.i686
    php54-devel-5.4.41-1.69.amzn1.i686
    php54-common-5.4.41-1.69.amzn1.i686
    php54-5.4.41-1.69.amzn1.i686

src:
    php54-5.4.41-1.69.amzn1.src

x86_64:
    php54-intl-5.4.41-1.69.amzn1.x86_64
    php54-mysql-5.4.41-1.69.amzn1.x86_64
    php54-common-5.4.41-1.69.amzn1.x86_64
    php54-gd-5.4.41-1.69.amzn1.x86_64
    php54-5.4.41-1.69.amzn1.x86_64
    php54-tidy-5.4.41-1.69.amzn1.x86_64
    php54-ldap-5.4.41-1.69.amzn1.x86_64
    php54-mssql-5.4.41-1.69.amzn1.x86_64
    php54-imap-5.4.41-1.69.amzn1.x86_64
    php54-xml-5.4.41-1.69.amzn1.x86_64
    php54-embedded-5.4.41-1.69.amzn1.x86_64
    php54-cli-5.4.41-1.69.amzn1.x86_64
    php54-enchant-5.4.41-1.69.amzn1.x86_64
    php54-pdo-5.4.41-1.69.amzn1.x86_64
    php54-odbc-5.4.41-1.69.amzn1.x86_64
    php54-soap-5.4.41-1.69.amzn1.x86_64
    php54-pgsql-5.4.41-1.69.amzn1.x86_64
    php54-pspell-5.4.41-1.69.amzn1.x86_64
    php54-recode-5.4.41-1.69.amzn1.x86_64
    php54-mysqlnd-5.4.41-1.69.amzn1.x86_64
    php54-process-5.4.41-1.69.amzn1.x86_64
    php54-debuginfo-5.4.41-1.69.amzn1.x86_64
    php54-xmlrpc-5.4.41-1.69.amzn1.x86_64
    php54-devel-5.4.41-1.69.amzn1.x86_64
    php54-fpm-5.4.41-1.69.amzn1.x86_64
    php54-dba-5.4.41-1.69.amzn1.x86_64
    php54-bcmath-5.4.41-1.69.amzn1.x86_64
    php54-mcrypt-5.4.41-1.69.amzn1.x86_64
    php54-snmp-5.4.41-1.69.amzn1.x86_64
    php54-mbstring-5.4.41-1.69.amzn1.x86_64