ALAS-2015-543


Amazon Linux AMI Security Advisory: ALAS-2015-543
Advisory Release Date: 2015-06-16 11:41 Pacific
Severity: Medium
References: CVE-2014-3215 

Issue Overview:

A flaw was found in the way seunshare, a utility for running executables under a different security context, used the capng_lock functionality of the libcap-ng library. The subsequent invocation of suid root binaries that relied on the fact that the setuid() system call, among others, also sets the saved set-user-ID when dropping the binaries' process privileges, could allow a local, unprivileged user to potentially escalate their privileges on the system.


Affected Packages:

libcap-ng


Issue Correction:
Run yum update libcap-ng to update your system.

New Packages:
i686:
    libcap-ng-utils-0.7.3-5.13.amzn1.i686
    libcap-ng-python-0.7.3-5.13.amzn1.i686
    libcap-ng-debuginfo-0.7.3-5.13.amzn1.i686
    libcap-ng-0.7.3-5.13.amzn1.i686
    libcap-ng-devel-0.7.3-5.13.amzn1.i686

src:
    libcap-ng-0.7.3-5.13.amzn1.src

x86_64:
    libcap-ng-0.7.3-5.13.amzn1.x86_64
    libcap-ng-debuginfo-0.7.3-5.13.amzn1.x86_64
    libcap-ng-python-0.7.3-5.13.amzn1.x86_64
    libcap-ng-devel-0.7.3-5.13.amzn1.x86_64
    libcap-ng-utils-0.7.3-5.13.amzn1.x86_64