ALAS-2015-545


Amazon Linux AMI Security Advisory: ALAS-2015-545
Advisory Release Date: 2015-06-16 11:42 Pacific
Severity: Medium
References: CVE-2015-3165 

Issue Overview:

Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 allows remote attackers to cause a denial of service (crash) by closing an SSL session at a time when the authentication timeout will expire during the session shutdown sequence.


Affected Packages:

postgresql92


Issue Correction:
Run yum update postgresql92 to update your system.

New Packages:
i686:
    postgresql92-plpython26-9.2.13-1.54.amzn1.i686
    postgresql92-docs-9.2.13-1.54.amzn1.i686
    postgresql92-contrib-9.2.13-1.54.amzn1.i686
    postgresql92-debuginfo-9.2.13-1.54.amzn1.i686
    postgresql92-plpython27-9.2.13-1.54.amzn1.i686
    postgresql92-server-compat-9.2.13-1.54.amzn1.i686
    postgresql92-libs-9.2.13-1.54.amzn1.i686
    postgresql92-server-9.2.13-1.54.amzn1.i686
    postgresql92-pltcl-9.2.13-1.54.amzn1.i686
    postgresql92-test-9.2.13-1.54.amzn1.i686
    postgresql92-plperl-9.2.13-1.54.amzn1.i686
    postgresql92-9.2.13-1.54.amzn1.i686
    postgresql92-devel-9.2.13-1.54.amzn1.i686

src:
    postgresql92-9.2.13-1.54.amzn1.src

x86_64:
    postgresql92-contrib-9.2.13-1.54.amzn1.x86_64
    postgresql92-plpython27-9.2.13-1.54.amzn1.x86_64
    postgresql92-server-9.2.13-1.54.amzn1.x86_64
    postgresql92-debuginfo-9.2.13-1.54.amzn1.x86_64
    postgresql92-libs-9.2.13-1.54.amzn1.x86_64
    postgresql92-server-compat-9.2.13-1.54.amzn1.x86_64
    postgresql92-9.2.13-1.54.amzn1.x86_64
    postgresql92-pltcl-9.2.13-1.54.amzn1.x86_64
    postgresql92-plpython26-9.2.13-1.54.amzn1.x86_64
    postgresql92-test-9.2.13-1.54.amzn1.x86_64
    postgresql92-plperl-9.2.13-1.54.amzn1.x86_64
    postgresql92-devel-9.2.13-1.54.amzn1.x86_64
    postgresql92-docs-9.2.13-1.54.amzn1.x86_64