ALAS-2015-546


Amazon Linux AMI Security Advisory: ALAS-2015-546
Advisory Release Date: 2015-06-16 11:42 Pacific
Severity: Medium
References: CVE-2015-3165 

Issue Overview:

Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 allows remote attackers to cause a denial of service (crash) by closing an SSL session at a time when the authentication timeout will expire during the session shutdown sequence.


Affected Packages:

postgresql93


Issue Correction:
Run yum update postgresql93 to update your system.

New Packages:
i686:
    postgresql93-plpython26-9.3.9-1.58.amzn1.i686
    postgresql93-debuginfo-9.3.9-1.58.amzn1.i686
    postgresql93-devel-9.3.9-1.58.amzn1.i686
    postgresql93-9.3.9-1.58.amzn1.i686
    postgresql93-plperl-9.3.9-1.58.amzn1.i686
    postgresql93-libs-9.3.9-1.58.amzn1.i686
    postgresql93-docs-9.3.9-1.58.amzn1.i686
    postgresql93-pltcl-9.3.9-1.58.amzn1.i686
    postgresql93-test-9.3.9-1.58.amzn1.i686
    postgresql93-plpython27-9.3.9-1.58.amzn1.i686
    postgresql93-contrib-9.3.9-1.58.amzn1.i686
    postgresql93-server-9.3.9-1.58.amzn1.i686

src:
    postgresql93-9.3.9-1.58.amzn1.src

x86_64:
    postgresql93-docs-9.3.9-1.58.amzn1.x86_64
    postgresql93-debuginfo-9.3.9-1.58.amzn1.x86_64
    postgresql93-pltcl-9.3.9-1.58.amzn1.x86_64
    postgresql93-devel-9.3.9-1.58.amzn1.x86_64
    postgresql93-server-9.3.9-1.58.amzn1.x86_64
    postgresql93-plpython27-9.3.9-1.58.amzn1.x86_64
    postgresql93-test-9.3.9-1.58.amzn1.x86_64
    postgresql93-libs-9.3.9-1.58.amzn1.x86_64
    postgresql93-plpython26-9.3.9-1.58.amzn1.x86_64
    postgresql93-9.3.9-1.58.amzn1.x86_64
    postgresql93-contrib-9.3.9-1.58.amzn1.x86_64
    postgresql93-plperl-9.3.9-1.58.amzn1.x86_64