ALAS-2015-561


Amazon Linux AMI Security Advisory: ALAS-2015-561
Advisory Release Date: 2015-07-07 22:41 Pacific
Severity: Medium

Issue Overview:

Upstream reports that six security-related issues in PHP were fixed in this release, as well as several security issues in bundled sqlite library (CVE-2015-3414 , CVE-2015-3415 , CVE-2015-3416 ). All PHP 5.4 users are encouraged to upgrade to this version. Please see the upstream release notes for full details.


Affected Packages:

php54


Issue Correction:
Run yum update php54 to update your system.

New Packages:
i686:
    php54-mssql-5.4.42-1.71.amzn1.i686
    php54-devel-5.4.42-1.71.amzn1.i686
    php54-xml-5.4.42-1.71.amzn1.i686
    php54-imap-5.4.42-1.71.amzn1.i686
    php54-odbc-5.4.42-1.71.amzn1.i686
    php54-debuginfo-5.4.42-1.71.amzn1.i686
    php54-pdo-5.4.42-1.71.amzn1.i686
    php54-snmp-5.4.42-1.71.amzn1.i686
    php54-mysql-5.4.42-1.71.amzn1.i686
    php54-5.4.42-1.71.amzn1.i686
    php54-tidy-5.4.42-1.71.amzn1.i686
    php54-dba-5.4.42-1.71.amzn1.i686
    php54-pspell-5.4.42-1.71.amzn1.i686
    php54-ldap-5.4.42-1.71.amzn1.i686
    php54-xmlrpc-5.4.42-1.71.amzn1.i686
    php54-pgsql-5.4.42-1.71.amzn1.i686
    php54-common-5.4.42-1.71.amzn1.i686
    php54-intl-5.4.42-1.71.amzn1.i686
    php54-enchant-5.4.42-1.71.amzn1.i686
    php54-mysqlnd-5.4.42-1.71.amzn1.i686
    php54-soap-5.4.42-1.71.amzn1.i686
    php54-fpm-5.4.42-1.71.amzn1.i686
    php54-recode-5.4.42-1.71.amzn1.i686
    php54-mbstring-5.4.42-1.71.amzn1.i686
    php54-process-5.4.42-1.71.amzn1.i686
    php54-mcrypt-5.4.42-1.71.amzn1.i686
    php54-bcmath-5.4.42-1.71.amzn1.i686
    php54-gd-5.4.42-1.71.amzn1.i686
    php54-embedded-5.4.42-1.71.amzn1.i686
    php54-cli-5.4.42-1.71.amzn1.i686

src:
    php54-5.4.42-1.71.amzn1.src

x86_64:
    php54-tidy-5.4.42-1.71.amzn1.x86_64
    php54-gd-5.4.42-1.71.amzn1.x86_64
    php54-ldap-5.4.42-1.71.amzn1.x86_64
    php54-bcmath-5.4.42-1.71.amzn1.x86_64
    php54-5.4.42-1.71.amzn1.x86_64
    php54-process-5.4.42-1.71.amzn1.x86_64
    php54-mbstring-5.4.42-1.71.amzn1.x86_64
    php54-devel-5.4.42-1.71.amzn1.x86_64
    php54-xml-5.4.42-1.71.amzn1.x86_64
    php54-mysql-5.4.42-1.71.amzn1.x86_64
    php54-embedded-5.4.42-1.71.amzn1.x86_64
    php54-odbc-5.4.42-1.71.amzn1.x86_64
    php54-recode-5.4.42-1.71.amzn1.x86_64
    php54-imap-5.4.42-1.71.amzn1.x86_64
    php54-cli-5.4.42-1.71.amzn1.x86_64
    php54-snmp-5.4.42-1.71.amzn1.x86_64
    php54-mcrypt-5.4.42-1.71.amzn1.x86_64
    php54-debuginfo-5.4.42-1.71.amzn1.x86_64
    php54-intl-5.4.42-1.71.amzn1.x86_64
    php54-fpm-5.4.42-1.71.amzn1.x86_64
    php54-xmlrpc-5.4.42-1.71.amzn1.x86_64
    php54-pgsql-5.4.42-1.71.amzn1.x86_64
    php54-mssql-5.4.42-1.71.amzn1.x86_64
    php54-mysqlnd-5.4.42-1.71.amzn1.x86_64
    php54-enchant-5.4.42-1.71.amzn1.x86_64
    php54-dba-5.4.42-1.71.amzn1.x86_64
    php54-common-5.4.42-1.71.amzn1.x86_64
    php54-pspell-5.4.42-1.71.amzn1.x86_64
    php54-pdo-5.4.42-1.71.amzn1.x86_64
    php54-soap-5.4.42-1.71.amzn1.x86_64