ALAS-2015-563


Amazon Linux AMI Security Advisory: ALAS-2015-563
Advisory Release Date: 2015-07-07 22:39 Pacific
Severity: Medium

Issue Overview:

Upstream reports that several bugs have been fixed as well as several security issues into some bundled libraries (CVE-2015-3414 , CVE-2015-3415 , CVE-2015-3416 , CVE-2015-2325 and CVE-2015-2326 ). All PHP 5.6 users are encouraged to upgrade to this version. Please see the upstream release notes for full details.


Affected Packages:

php56


Issue Correction:
Run yum update php56 to update your system.

New Packages:
i686:
    php56-intl-5.6.10-1.115.amzn1.i686
    php56-enchant-5.6.10-1.115.amzn1.i686
    php56-snmp-5.6.10-1.115.amzn1.i686
    php56-fpm-5.6.10-1.115.amzn1.i686
    php56-pgsql-5.6.10-1.115.amzn1.i686
    php56-mssql-5.6.10-1.115.amzn1.i686
    php56-dba-5.6.10-1.115.amzn1.i686
    php56-odbc-5.6.10-1.115.amzn1.i686
    php56-mysqlnd-5.6.10-1.115.amzn1.i686
    php56-mbstring-5.6.10-1.115.amzn1.i686
    php56-5.6.10-1.115.amzn1.i686
    php56-tidy-5.6.10-1.115.amzn1.i686
    php56-pdo-5.6.10-1.115.amzn1.i686
    php56-gd-5.6.10-1.115.amzn1.i686
    php56-pspell-5.6.10-1.115.amzn1.i686
    php56-recode-5.6.10-1.115.amzn1.i686
    php56-opcache-5.6.10-1.115.amzn1.i686
    php56-embedded-5.6.10-1.115.amzn1.i686
    php56-dbg-5.6.10-1.115.amzn1.i686
    php56-gmp-5.6.10-1.115.amzn1.i686
    php56-debuginfo-5.6.10-1.115.amzn1.i686
    php56-common-5.6.10-1.115.amzn1.i686
    php56-ldap-5.6.10-1.115.amzn1.i686
    php56-bcmath-5.6.10-1.115.amzn1.i686
    php56-soap-5.6.10-1.115.amzn1.i686
    php56-devel-5.6.10-1.115.amzn1.i686
    php56-mcrypt-5.6.10-1.115.amzn1.i686
    php56-imap-5.6.10-1.115.amzn1.i686
    php56-xml-5.6.10-1.115.amzn1.i686
    php56-cli-5.6.10-1.115.amzn1.i686
    php56-process-5.6.10-1.115.amzn1.i686
    php56-xmlrpc-5.6.10-1.115.amzn1.i686

src:
    php56-5.6.10-1.115.amzn1.src

x86_64:
    php56-common-5.6.10-1.115.amzn1.x86_64
    php56-dba-5.6.10-1.115.amzn1.x86_64
    php56-mbstring-5.6.10-1.115.amzn1.x86_64
    php56-enchant-5.6.10-1.115.amzn1.x86_64
    php56-debuginfo-5.6.10-1.115.amzn1.x86_64
    php56-devel-5.6.10-1.115.amzn1.x86_64
    php56-process-5.6.10-1.115.amzn1.x86_64
    php56-odbc-5.6.10-1.115.amzn1.x86_64
    php56-xml-5.6.10-1.115.amzn1.x86_64
    php56-bcmath-5.6.10-1.115.amzn1.x86_64
    php56-imap-5.6.10-1.115.amzn1.x86_64
    php56-embedded-5.6.10-1.115.amzn1.x86_64
    php56-dbg-5.6.10-1.115.amzn1.x86_64
    php56-pgsql-5.6.10-1.115.amzn1.x86_64
    php56-ldap-5.6.10-1.115.amzn1.x86_64
    php56-xmlrpc-5.6.10-1.115.amzn1.x86_64
    php56-mysqlnd-5.6.10-1.115.amzn1.x86_64
    php56-recode-5.6.10-1.115.amzn1.x86_64
    php56-gmp-5.6.10-1.115.amzn1.x86_64
    php56-intl-5.6.10-1.115.amzn1.x86_64
    php56-mcrypt-5.6.10-1.115.amzn1.x86_64
    php56-mssql-5.6.10-1.115.amzn1.x86_64
    php56-snmp-5.6.10-1.115.amzn1.x86_64
    php56-pspell-5.6.10-1.115.amzn1.x86_64
    php56-cli-5.6.10-1.115.amzn1.x86_64
    php56-fpm-5.6.10-1.115.amzn1.x86_64
    php56-gd-5.6.10-1.115.amzn1.x86_64
    php56-pdo-5.6.10-1.115.amzn1.x86_64
    php56-tidy-5.6.10-1.115.amzn1.x86_64
    php56-5.6.10-1.115.amzn1.x86_64
    php56-opcache-5.6.10-1.115.amzn1.x86_64
    php56-soap-5.6.10-1.115.amzn1.x86_64