ALAS-2015-566


Amazon Linux AMI Security Advisory: ALAS-2015-566
Advisory Release Date: 2015-07-22 10:00 Pacific
Severity: Important
References: CVE-2015-4620 

Issue Overview:

A flaw was found in the way BIND performed DNSSEC validation. An attacker able to make BIND (functioning as a DNS resolver with DNSSEC validation enabled) resolve a name in an attacker-controlled domain could cause named to exit unexpectedly with an assertion failure.


Affected Packages:

bind


Issue Correction:
Run yum update bind to update your system.

New Packages:
i686:
    bind-libs-9.8.2-0.30.rc1.37.amzn1.i686
    bind-debuginfo-9.8.2-0.30.rc1.37.amzn1.i686
    bind-devel-9.8.2-0.30.rc1.37.amzn1.i686
    bind-9.8.2-0.30.rc1.37.amzn1.i686
    bind-chroot-9.8.2-0.30.rc1.37.amzn1.i686
    bind-sdb-9.8.2-0.30.rc1.37.amzn1.i686
    bind-utils-9.8.2-0.30.rc1.37.amzn1.i686

src:
    bind-9.8.2-0.30.rc1.37.amzn1.src

x86_64:
    bind-devel-9.8.2-0.30.rc1.37.amzn1.x86_64
    bind-chroot-9.8.2-0.30.rc1.37.amzn1.x86_64
    bind-utils-9.8.2-0.30.rc1.37.amzn1.x86_64
    bind-9.8.2-0.30.rc1.37.amzn1.x86_64
    bind-debuginfo-9.8.2-0.30.rc1.37.amzn1.x86_64
    bind-sdb-9.8.2-0.30.rc1.37.amzn1.x86_64
    bind-libs-9.8.2-0.30.rc1.37.amzn1.x86_64