ALAS-2015-589


Amazon Linux AMI Security Advisory: ALAS-2015-589
Advisory Release Date: 2015-09-02 12:00 Pacific
Severity: Medium

Issue Overview:

It was discovered that the _unix_run_helper_binary() function of PAM's unix_pam module could write to a blocking pipe, possibly causing the function to become unresponsive. An attacker able to supply large passwords to the unix_pam module could use this flaw to enumerate valid user accounts, or cause a denial of service on the system. (CVE-2015-3238 )


Affected Packages:

pam


Issue Correction:
Run yum update pam to update your system.

New Packages:
i686:
    pam-devel-1.1.8-12.32.amzn1.i686
    pam-1.1.8-12.32.amzn1.i686
    pam-debuginfo-1.1.8-12.32.amzn1.i686

src:
    pam-1.1.8-12.32.amzn1.src

x86_64:
    pam-devel-1.1.8-12.32.amzn1.x86_64
    pam-1.1.8-12.32.amzn1.x86_64
    pam-debuginfo-1.1.8-12.32.amzn1.x86_64