ALAS-2015-598


Amazon Linux AMI Security Advisory: ALAS-2015-598
Advisory Release Date: 2015-09-22 10:00 Pacific
Severity: Low

Issue Overview:

An integer overflow flaw, leading to a heap-based buffer overflow, was found in the way grep parsed large lines of data. An attacker able to trick a user into running grep on a specially crafted data file could use this flaw to crash grep or, potentially, execute arbitrary code with the privileges of the user running grep. (CVE-2012-5667 )

A heap-based buffer overflow flaw was found in the way grep processed certain pattern and text combinations. An attacker able to trick a user into running grep on specially crafted input could use this flaw to crash grep or, potentially, read from uninitialized memory. (CVE-2015-1345 )


Affected Packages:

grep


Issue Correction:
Run yum update grep to update your system.

New Packages:
i686:
    grep-2.20-1.14.amzn1.i686
    grep-debuginfo-2.20-1.14.amzn1.i686

src:
    grep-2.20-1.14.amzn1.src

x86_64:
    grep-debuginfo-2.20-1.14.amzn1.x86_64
    grep-2.20-1.14.amzn1.x86_64