ALAS-2015-599


Amazon Linux AMI Security Advisory: ALAS-2015-599
Advisory Release Date: 2015-10-09 17:06 Pacific
Severity: Important

Issue Overview:

A flaw was found in the way the OpenLDAP server daemon (slapd) parsed certain Basic Encoding Rules (BER) data. A remote attacker could use this flaw to crash slapd via a specially crafted packet. (CVE-2015-6908 )


Affected Packages:

openldap,compat-openldap


Issue Correction:
Run yum update openldap to update your system.

New Packages:
i686:
    openldap-devel-2.4.23-34.25.amzn1.i686
    openldap-servers-sql-2.4.23-34.25.amzn1.i686
    openldap-servers-2.4.23-34.25.amzn1.i686
    openldap-clients-2.4.23-34.25.amzn1.i686
    openldap-2.4.23-34.25.amzn1.i686
    openldap-debuginfo-2.4.23-34.25.amzn1.i686
    compat-openldap-debuginfo-2.3.43-2.5.amzn1.i686
    compat-openldap-2.3.43-2.5.amzn1.i686

src:
    openldap-2.4.23-34.25.amzn1.src
    compat-openldap-2.3.43-2.5.amzn1.src

x86_64:
    openldap-debuginfo-2.4.23-34.25.amzn1.x86_64
    openldap-servers-sql-2.4.23-34.25.amzn1.x86_64
    openldap-devel-2.4.23-34.25.amzn1.x86_64
    openldap-2.4.23-34.25.amzn1.x86_64
    openldap-clients-2.4.23-34.25.amzn1.x86_64
    openldap-servers-2.4.23-34.25.amzn1.x86_64
    compat-openldap-debuginfo-2.3.43-2.5.amzn1.x86_64
    compat-openldap-2.3.43-2.5.amzn1.x86_64