ALAS-2015-609


Amazon Linux AMI Security Advisory: ALAS-2015-609
Advisory Release Date: 2015-11-05 03:26 Pacific
Severity: Medium

Issue Overview:

Multiple stack-based buffer overflows in json parsing in PostgreSQL before 9.3.x before 9.3.10 and 9.4.x before 9.4.5 allow attackers to cause a denial of service (server crash) via unspecified vectors, which are not properly handled in (1) json or (2) jsonb values. (CVE-2015-5289 )

The crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23, 9.1.x before 9.1.19, 9.2.x before 9.2.14, 9.3.x before 9.3.10, and 9.4.x before 9.4.5 allows attackers to cause a denial of service (server crash) or read arbitrary server memory via a "too-short" salt. (CVE-2015-5288 )


Affected Packages:

postgresql92,postgresql93,postgresql94


Issue Correction:
Run yum update postgresql92 to update your system.
Run yum update postgresql93 to update your system.
Run yum update postgresql94 to update your system.

New Packages:
i686:
    postgresql92-plperl-9.2.14-1.56.amzn1.i686
    postgresql92-server-9.2.14-1.56.amzn1.i686
    postgresql92-plpython26-9.2.14-1.56.amzn1.i686
    postgresql92-9.2.14-1.56.amzn1.i686
    postgresql92-debuginfo-9.2.14-1.56.amzn1.i686
    postgresql92-docs-9.2.14-1.56.amzn1.i686
    postgresql92-libs-9.2.14-1.56.amzn1.i686
    postgresql92-test-9.2.14-1.56.amzn1.i686
    postgresql92-devel-9.2.14-1.56.amzn1.i686
    postgresql92-server-compat-9.2.14-1.56.amzn1.i686
    postgresql92-plpython27-9.2.14-1.56.amzn1.i686
    postgresql92-contrib-9.2.14-1.56.amzn1.i686
    postgresql92-pltcl-9.2.14-1.56.amzn1.i686
    postgresql93-libs-9.3.10-1.60.amzn1.i686
    postgresql93-plpython26-9.3.10-1.60.amzn1.i686
    postgresql93-plpython27-9.3.10-1.60.amzn1.i686
    postgresql93-docs-9.3.10-1.60.amzn1.i686
    postgresql93-contrib-9.3.10-1.60.amzn1.i686
    postgresql93-devel-9.3.10-1.60.amzn1.i686
    postgresql93-test-9.3.10-1.60.amzn1.i686
    postgresql93-9.3.10-1.60.amzn1.i686
    postgresql93-pltcl-9.3.10-1.60.amzn1.i686
    postgresql93-plperl-9.3.10-1.60.amzn1.i686
    postgresql93-server-9.3.10-1.60.amzn1.i686
    postgresql93-debuginfo-9.3.10-1.60.amzn1.i686
    postgresql94-libs-9.4.5-1.63.amzn1.i686
    postgresql94-devel-9.4.5-1.63.amzn1.i686
    postgresql94-test-9.4.5-1.63.amzn1.i686
    postgresql94-docs-9.4.5-1.63.amzn1.i686
    postgresql94-server-9.4.5-1.63.amzn1.i686
    postgresql94-9.4.5-1.63.amzn1.i686
    postgresql94-pltcl-9.4.5-1.63.amzn1.i686
    postgresql94-plperl-9.4.5-1.63.amzn1.i686
    postgresql94-plpython26-9.4.5-1.63.amzn1.i686
    postgresql94-debuginfo-9.4.5-1.63.amzn1.i686
    postgresql94-contrib-9.4.5-1.63.amzn1.i686
    postgresql94-plpython27-9.4.5-1.63.amzn1.i686

src:
    postgresql92-9.2.14-1.56.amzn1.src
    postgresql93-9.3.10-1.60.amzn1.src
    postgresql94-9.4.5-1.63.amzn1.src

x86_64:
    postgresql92-test-9.2.14-1.56.amzn1.x86_64
    postgresql92-contrib-9.2.14-1.56.amzn1.x86_64
    postgresql92-devel-9.2.14-1.56.amzn1.x86_64
    postgresql92-plperl-9.2.14-1.56.amzn1.x86_64
    postgresql92-server-9.2.14-1.56.amzn1.x86_64
    postgresql92-debuginfo-9.2.14-1.56.amzn1.x86_64
    postgresql92-plpython27-9.2.14-1.56.amzn1.x86_64
    postgresql92-9.2.14-1.56.amzn1.x86_64
    postgresql92-plpython26-9.2.14-1.56.amzn1.x86_64
    postgresql92-pltcl-9.2.14-1.56.amzn1.x86_64
    postgresql92-docs-9.2.14-1.56.amzn1.x86_64
    postgresql92-server-compat-9.2.14-1.56.amzn1.x86_64
    postgresql92-libs-9.2.14-1.56.amzn1.x86_64
    postgresql93-plperl-9.3.10-1.60.amzn1.x86_64
    postgresql93-plpython27-9.3.10-1.60.amzn1.x86_64
    postgresql93-pltcl-9.3.10-1.60.amzn1.x86_64
    postgresql93-test-9.3.10-1.60.amzn1.x86_64
    postgresql93-9.3.10-1.60.amzn1.x86_64
    postgresql93-contrib-9.3.10-1.60.amzn1.x86_64
    postgresql93-devel-9.3.10-1.60.amzn1.x86_64
    postgresql93-server-9.3.10-1.60.amzn1.x86_64
    postgresql93-plpython26-9.3.10-1.60.amzn1.x86_64
    postgresql93-libs-9.3.10-1.60.amzn1.x86_64
    postgresql93-debuginfo-9.3.10-1.60.amzn1.x86_64
    postgresql93-docs-9.3.10-1.60.amzn1.x86_64
    postgresql94-libs-9.4.5-1.63.amzn1.x86_64
    postgresql94-test-9.4.5-1.63.amzn1.x86_64
    postgresql94-pltcl-9.4.5-1.63.amzn1.x86_64
    postgresql94-contrib-9.4.5-1.63.amzn1.x86_64
    postgresql94-plpython26-9.4.5-1.63.amzn1.x86_64
    postgresql94-9.4.5-1.63.amzn1.x86_64
    postgresql94-devel-9.4.5-1.63.amzn1.x86_64
    postgresql94-server-9.4.5-1.63.amzn1.x86_64
    postgresql94-docs-9.4.5-1.63.amzn1.x86_64
    postgresql94-plpython27-9.4.5-1.63.amzn1.x86_64
    postgresql94-plperl-9.4.5-1.63.amzn1.x86_64
    postgresql94-debuginfo-9.4.5-1.63.amzn1.x86_64