ALAS-2015-611


Amazon Linux AMI Security Advisory: ALAS-2015-611
Advisory Release Date: 2015-11-23 22:53 Pacific
Severity: Medium
References: CVE-2015-8126 

Issue Overview:

Multiple buffer overflows in the png_set_PLTE and png_get_PLTE functions in libpng before 1.0.64, 1.1.x and 1.2.x before 1.2.54, 1.3.x and 1.4.x before 1.4.17, 1.5.x before 1.5.24, and 1.6.x before 1.6.19, allowing remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a small bit-depth value in an IHDR (aka image header) chunk in a PNG image (CVE-2015-8126 ).


Affected Packages:

libpng


Issue Correction:
Run yum update libpng to update your system.

New Packages:
i686:
    libpng-static-1.2.49-1.13.amzn1.i686
    libpng-debuginfo-1.2.49-1.13.amzn1.i686
    libpng-devel-1.2.49-1.13.amzn1.i686
    libpng-1.2.49-1.13.amzn1.i686

src:
    libpng-1.2.49-1.13.amzn1.src

x86_64:
    libpng-devel-1.2.49-1.13.amzn1.x86_64
    libpng-static-1.2.49-1.13.amzn1.x86_64
    libpng-1.2.49-1.13.amzn1.x86_64
    libpng-debuginfo-1.2.49-1.13.amzn1.x86_64