ALAS-2015-619


Amazon Linux AMI Security Advisory: ALAS-2015-619
Advisory Release Date: 2015-12-13 14:20 Pacific
Severity: Medium

Issue Overview:

A memory leak error was discovered in the crypt() function of the pgCrypto extension. An authenticated attacker could possibly use this flaw to disclose a limited amount of the server memory. (CVE-2015-5288 )


Affected Packages:

postgresql8


Issue Correction:
Run yum update postgresql8 to update your system.

New Packages:
i686:
    postgresql8-plperl-8.4.20-4.51.amzn1.i686
    postgresql8-test-8.4.20-4.51.amzn1.i686
    postgresql8-plpython-8.4.20-4.51.amzn1.i686
    postgresql8-8.4.20-4.51.amzn1.i686
    postgresql8-libs-8.4.20-4.51.amzn1.i686
    postgresql8-devel-8.4.20-4.51.amzn1.i686
    postgresql8-debuginfo-8.4.20-4.51.amzn1.i686
    postgresql8-contrib-8.4.20-4.51.amzn1.i686
    postgresql8-server-8.4.20-4.51.amzn1.i686
    postgresql8-docs-8.4.20-4.51.amzn1.i686
    postgresql8-pltcl-8.4.20-4.51.amzn1.i686

src:
    postgresql8-8.4.20-4.51.amzn1.src

x86_64:
    postgresql8-8.4.20-4.51.amzn1.x86_64
    postgresql8-docs-8.4.20-4.51.amzn1.x86_64
    postgresql8-libs-8.4.20-4.51.amzn1.x86_64
    postgresql8-devel-8.4.20-4.51.amzn1.x86_64
    postgresql8-test-8.4.20-4.51.amzn1.x86_64
    postgresql8-pltcl-8.4.20-4.51.amzn1.x86_64
    postgresql8-contrib-8.4.20-4.51.amzn1.x86_64
    postgresql8-server-8.4.20-4.51.amzn1.x86_64
    postgresql8-plpython-8.4.20-4.51.amzn1.x86_64
    postgresql8-debuginfo-8.4.20-4.51.amzn1.x86_64
    postgresql8-plperl-8.4.20-4.51.amzn1.x86_64