ALAS-2016-660


Amazon Linux AMI Security Advisory: ALAS-2016-660
Advisory Release Date: 2016-03-10 16:30 Pacific
Severity: Low
References: CVE-2015-5229 

Issue Overview:

It was discovered that the calloc implementation in glibc could return memory areas which contain non-zero bytes. This could result in unexpected application behavior such as hangs or crashes.


Affected Packages:

glibc


Issue Correction:
Run yum update glibc to update your system.

New Packages:
i686:
    glibc-debuginfo-2.17-106.167.amzn1.i686
    glibc-debuginfo-common-2.17-106.167.amzn1.i686
    glibc-devel-2.17-106.167.amzn1.i686
    glibc-headers-2.17-106.167.amzn1.i686
    nscd-2.17-106.167.amzn1.i686
    glibc-utils-2.17-106.167.amzn1.i686
    glibc-2.17-106.167.amzn1.i686
    glibc-common-2.17-106.167.amzn1.i686
    glibc-static-2.17-106.167.amzn1.i686

src:
    glibc-2.17-106.167.amzn1.src

x86_64:
    glibc-2.17-106.167.amzn1.x86_64
    glibc-static-2.17-106.167.amzn1.x86_64
    glibc-headers-2.17-106.167.amzn1.x86_64
    glibc-utils-2.17-106.167.amzn1.x86_64
    glibc-devel-2.17-106.167.amzn1.x86_64
    glibc-common-2.17-106.167.amzn1.x86_64
    glibc-debuginfo-common-2.17-106.167.amzn1.x86_64
    nscd-2.17-106.167.amzn1.x86_64
    glibc-debuginfo-2.17-106.167.amzn1.x86_64