ALAS-2016-667


Amazon Linux AMI Security Advisory: ALAS-2016-667
Advisory Release Date: 2016-03-10 16:30 Pacific
Severity: Critical
References: CVE-2016-1950 

Issue Overview:

A heap-based buffer overflow flaw was found in the way NSS parsed certain ASN.1 structures. An attacker could use this flaw to create a specially crafted certificate which, when parsed by NSS, could cause it to crash, or execute arbitrary code, using the permissions of the user running an application compiled against the NSS library.


Affected Packages:

nss-util


Issue Correction:
Run yum update nss-util to update your system.

New Packages:
i686:
    nss-util-3.19.1-9.49.amzn1.i686
    nss-util-devel-3.19.1-9.49.amzn1.i686
    nss-util-debuginfo-3.19.1-9.49.amzn1.i686

src:
    nss-util-3.19.1-9.49.amzn1.src

x86_64:
    nss-util-3.19.1-9.49.amzn1.x86_64
    nss-util-devel-3.19.1-9.49.amzn1.x86_64
    nss-util-debuginfo-3.19.1-9.49.amzn1.x86_64