ALAS-2016-675


Amazon Linux AMI Security Advisory: ALAS-2016-675
Advisory Release Date: 2016-03-29 15:30 Pacific
Severity: Medium
References: CVE-2016-1908 

Issue Overview:

An access flaw was discovered in the OpenSSH client where it did not correctly handle failures to generate authentication cookies for untrusted X11 forwarding. A malicious or compromised remote X application could possibly use this flaw to establish a trusted connection to the local X server, even if only untrusted X11 forwarding was requested.


Affected Packages:

openssh


Issue Correction:
Run yum update openssh to update your system.

New Packages:
i686:
    openssh-clients-6.6.1p1-25.61.amzn1.i686
    openssh-ldap-6.6.1p1-25.61.amzn1.i686
    openssh-6.6.1p1-25.61.amzn1.i686
    openssh-debuginfo-6.6.1p1-25.61.amzn1.i686
    pam_ssh_agent_auth-0.9.3-9.25.61.amzn1.i686
    openssh-keycat-6.6.1p1-25.61.amzn1.i686
    openssh-server-6.6.1p1-25.61.amzn1.i686

src:
    openssh-6.6.1p1-25.61.amzn1.src

x86_64:
    openssh-debuginfo-6.6.1p1-25.61.amzn1.x86_64
    openssh-6.6.1p1-25.61.amzn1.x86_64
    pam_ssh_agent_auth-0.9.3-9.25.61.amzn1.x86_64
    openssh-ldap-6.6.1p1-25.61.amzn1.x86_64
    openssh-clients-6.6.1p1-25.61.amzn1.x86_64
    openssh-keycat-6.6.1p1-25.61.amzn1.x86_64
    openssh-server-6.6.1p1-25.61.amzn1.x86_64