ALAS-2016-689


Amazon Linux AMI Security Advisory: ALAS-2016-689
Advisory Release Date: 2016-04-21 16:00 Pacific
Severity: Important
References: CVE-2016-0773 

Issue Overview:

An integer overflow flaw, leading to a heap-based buffer overflow, was found in the PostgreSQL handling code for regular expressions. A remote attacker could use a specially crafted regular expression to cause PostgreSQL to crash or possibly execute arbitrary code.


Affected Packages:

postgresql8


Issue Correction:
Run yum update postgresql8 to update your system.

New Packages:
i686:
    postgresql8-devel-8.4.20-5.52.amzn1.i686
    postgresql8-8.4.20-5.52.amzn1.i686
    postgresql8-pltcl-8.4.20-5.52.amzn1.i686
    postgresql8-debuginfo-8.4.20-5.52.amzn1.i686
    postgresql8-plpython-8.4.20-5.52.amzn1.i686
    postgresql8-server-8.4.20-5.52.amzn1.i686
    postgresql8-libs-8.4.20-5.52.amzn1.i686
    postgresql8-plperl-8.4.20-5.52.amzn1.i686
    postgresql8-contrib-8.4.20-5.52.amzn1.i686
    postgresql8-test-8.4.20-5.52.amzn1.i686
    postgresql8-docs-8.4.20-5.52.amzn1.i686

src:
    postgresql8-8.4.20-5.52.amzn1.src

x86_64:
    postgresql8-libs-8.4.20-5.52.amzn1.x86_64
    postgresql8-docs-8.4.20-5.52.amzn1.x86_64
    postgresql8-plpython-8.4.20-5.52.amzn1.x86_64
    postgresql8-server-8.4.20-5.52.amzn1.x86_64
    postgresql8-devel-8.4.20-5.52.amzn1.x86_64
    postgresql8-debuginfo-8.4.20-5.52.amzn1.x86_64
    postgresql8-contrib-8.4.20-5.52.amzn1.x86_64
    postgresql8-pltcl-8.4.20-5.52.amzn1.x86_64
    postgresql8-8.4.20-5.52.amzn1.x86_64
    postgresql8-plperl-8.4.20-5.52.amzn1.x86_64
    postgresql8-test-8.4.20-5.52.amzn1.x86_64