ALAS-2016-690


Amazon Linux AMI Security Advisory: ALAS-2016-690
Advisory Release Date: 2016-04-21 16:00 Pacific
Severity: Medium

Issue Overview:

It was discovered that foomatic-rip failed to remove all shell special characters from inputs used to construct command lines for external programs run by the filter. An attacker could possibly use this flaw to execute arbitrary commands. (CVE-2015-8560 )

It was discovered that the unhtmlify() function of foomatic-rip did not correctly calculate buffer sizes, possibly leading to a heap-based memory corruption. A malicious attacker could exploit this flaw to cause foomatic-rip to crash or, possibly, execute arbitrary code. (CVE-2010-5325 )


Affected Packages:

foomatic


Issue Correction:
Run yum update foomatic to update your system.

New Packages:
i686:
    foomatic-debuginfo-4.0.4-5.11.amzn1.i686
    foomatic-4.0.4-5.11.amzn1.i686

src:
    foomatic-4.0.4-5.11.amzn1.src

x86_64:
    foomatic-4.0.4-5.11.amzn1.x86_64
    foomatic-debuginfo-4.0.4-5.11.amzn1.x86_64