ALAS-2016-695


Amazon Linux AMI Security Advisory: ALAS-2016-695
Advisory Release Date: 2016-05-03 10:30 Pacific
Severity: Important

Issue Overview:

A vulnerability was discovered that allows a man-in-the-middle attacker to use a padding oracle attack to decrypt traffic on a connection using an AES CBC cipher with a server supporting AES-NI. (CVE-2016-2107 , Important)

It was discovered that the ASN.1 parser can misinterpret a large universal tag as a negative value. If an application deserializes and later reserializes untrusted ASN.1 structures containing an ANY field, an attacker may be able to trigger an out-of-bounds write, which can cause potentially exploitable memory corruption. (CVE-2016-2108 , Important)

An overflow bug was discovered in the EVP_EncodeUpdate() function. An attacker could supply very large amounts of input data to overflow a length check, resulting in heap corruption. (CVE-2016-2105 , Low)

An overflow bug was discovered in the EVP_EncryptUpdate() function. An attacker could supply very large amounts of input data to overflow a length check, resulting in heap corruption. (CVE-2016-2106 , Low)

An issue was discovered in the BIO functions, such as d2i_CMS_bio(), where a short invalid encoding in ASN.1 data can cause allocation of large amounts of memory, potentially resulting in a denial of service. (CVE-2016-2109 , Low)


Affected Packages:

openssl


Issue Correction:
Run yum update openssl to update your system.

New Packages:
i686:
    openssl-static-1.0.1k-14.91.amzn1.i686
    openssl-1.0.1k-14.91.amzn1.i686
    openssl-perl-1.0.1k-14.91.amzn1.i686
    openssl-devel-1.0.1k-14.91.amzn1.i686
    openssl-debuginfo-1.0.1k-14.91.amzn1.i686

src:
    openssl-1.0.1k-14.91.amzn1.src

x86_64:
    openssl-perl-1.0.1k-14.91.amzn1.x86_64
    openssl-devel-1.0.1k-14.91.amzn1.x86_64
    openssl-debuginfo-1.0.1k-14.91.amzn1.x86_64
    openssl-static-1.0.1k-14.91.amzn1.x86_64
    openssl-1.0.1k-14.91.amzn1.x86_64