ALAS-2016-697


Amazon Linux AMI Security Advisory: ALAS-2016-697
Advisory Release Date: 2016-05-03 10:30 Pacific
Severity: Important

Issue Overview:

It was discovered that Mercurial failed to properly check Git sub-repository URLs. A Mercurial repository that includes a Git sub-repository with a specially crafted URL could cause Mercurial to execute arbitrary code. (CVE-2016-3068 )

The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records. (CVE-2016-3630 )

It was discovered that the Mercurial convert extension failed to sanitize special characters in Git repository names. A Git repository with a specially crafted name could cause Mercurial to execute arbitrary code when the Git repository was converted to a Mercurial repository. (CVE-2016-3069 )


Affected Packages:

mercurial


Issue Correction:
Run yum update mercurial to update your system.

New Packages:
i686:
    emacs-mercurial-3.5.2-1.26.amzn1.i686
    mercurial-python27-3.5.2-1.26.amzn1.i686
    mercurial-common-3.5.2-1.26.amzn1.i686
    mercurial-python26-3.5.2-1.26.amzn1.i686
    mercurial-debuginfo-3.5.2-1.26.amzn1.i686
    emacs-mercurial-el-3.5.2-1.26.amzn1.i686

src:
    mercurial-3.5.2-1.26.amzn1.src

x86_64:
    mercurial-debuginfo-3.5.2-1.26.amzn1.x86_64
    mercurial-common-3.5.2-1.26.amzn1.x86_64
    mercurial-python27-3.5.2-1.26.amzn1.x86_64
    emacs-mercurial-el-3.5.2-1.26.amzn1.x86_64
    mercurial-python26-3.5.2-1.26.amzn1.x86_64
    emacs-mercurial-3.5.2-1.26.amzn1.x86_64