ALAS-2016-730


Amazon Linux AMI Security Advisory: ALAS-2016-730
Advisory Release Date: 2016-08-17 13:30 Pacific
Severity: Medium

Issue Overview:

curl and libcurl before 7.50.1 do not prevent TLS session resumption when the client certificate has changed, which allows remote attackers to bypass intended restrictions by resuming a session. (CVE-2016-5419 )

curl and libcurl before 7.50.1 do not check the client certificate when choosing the TLS connection to reuse, which might allow remote attackers to hijack the authentication of the connection by leveraging a previously created connection with a different client certificate. (CVE-2016-5420 )

libcurl before 7.50.1 allows attackers to control which connection is used or possibly have unspecified other impact via unknown vectors. (CVE-2016-5421 )


Affected Packages:

curl


Issue Correction:
Run yum update curl to update your system.

New Packages:
i686:
    libcurl-7.40.0-8.59.amzn1.i686
    curl-debuginfo-7.40.0-8.59.amzn1.i686
    libcurl-devel-7.40.0-8.59.amzn1.i686
    curl-7.40.0-8.59.amzn1.i686

src:
    curl-7.40.0-8.59.amzn1.src

x86_64:
    curl-debuginfo-7.40.0-8.59.amzn1.x86_64
    curl-7.40.0-8.59.amzn1.x86_64
    libcurl-devel-7.40.0-8.59.amzn1.x86_64
    libcurl-7.40.0-8.59.amzn1.x86_64