ALAS-2016-745


Amazon Linux AMI Security Advisory: ALAS-2016-745
Advisory Release Date: 2016-09-15 19:00 Pacific
Severity: Medium
References: CVE-2016-2775 

Issue Overview:

It was found that the lightweight resolver could crash due to an error when asked to resolve a query name which, when combined with a search list entry, exceeds the maximum allowable length. A remote attacker could use this flaw to crash lwresd or named when using the "lwres" statement in named.conf.


Affected Packages:

bind


Issue Correction:
Run yum update bind to update your system.

New Packages:
i686:
    bind-libs-9.8.2-0.37.rc1.47.amzn1.i686
    bind-sdb-9.8.2-0.37.rc1.47.amzn1.i686
    bind-devel-9.8.2-0.37.rc1.47.amzn1.i686
    bind-debuginfo-9.8.2-0.37.rc1.47.amzn1.i686
    bind-9.8.2-0.37.rc1.47.amzn1.i686
    bind-utils-9.8.2-0.37.rc1.47.amzn1.i686
    bind-chroot-9.8.2-0.37.rc1.47.amzn1.i686

src:
    bind-9.8.2-0.37.rc1.47.amzn1.src

x86_64:
    bind-libs-9.8.2-0.37.rc1.47.amzn1.x86_64
    bind-9.8.2-0.37.rc1.47.amzn1.x86_64
    bind-devel-9.8.2-0.37.rc1.47.amzn1.x86_64
    bind-utils-9.8.2-0.37.rc1.47.amzn1.x86_64
    bind-sdb-9.8.2-0.37.rc1.47.amzn1.x86_64
    bind-chroot-9.8.2-0.37.rc1.47.amzn1.x86_64
    bind-debuginfo-9.8.2-0.37.rc1.47.amzn1.x86_64