ALAS-2016-757


Amazon Linux AMI Security Advisory: ALAS-2016-757
Advisory Release Date: 2016-11-10 18:00 Pacific
Severity: Critical
References: CVE-2016-5195 

Issue Overview:

A race condition was found in the way the Linux kernel's memory subsystem handled the copy-on-write (COW) breakage of private read-only memory mappings. An unprivileged local user could use this flaw to gain write access to otherwise read-only memory mappings and thus increase their privileges on the system.

(Updated 2016-11-10: This advisory was upgraded to Critical.)


Affected Packages:

kernel


Issue Correction:
Run yum update kernel to update your system. You will need to reboot your system in order for the new kernel to be running.

New Packages:
i686:
    kernel-4.4.23-31.54.amzn1.i686
    kernel-devel-4.4.23-31.54.amzn1.i686
    kernel-tools-debuginfo-4.4.23-31.54.amzn1.i686
    kernel-tools-devel-4.4.23-31.54.amzn1.i686
    kernel-debuginfo-common-i686-4.4.23-31.54.amzn1.i686
    perf-4.4.23-31.54.amzn1.i686
    kernel-debuginfo-4.4.23-31.54.amzn1.i686
    perf-debuginfo-4.4.23-31.54.amzn1.i686
    kernel-tools-4.4.23-31.54.amzn1.i686
    kernel-headers-4.4.23-31.54.amzn1.i686

noarch:
    kernel-doc-4.4.23-31.54.amzn1.noarch

src:
    kernel-4.4.23-31.54.amzn1.src

x86_64:
    kernel-tools-devel-4.4.23-31.54.amzn1.x86_64
    kernel-4.4.23-31.54.amzn1.x86_64
    kernel-tools-debuginfo-4.4.23-31.54.amzn1.x86_64
    perf-debuginfo-4.4.23-31.54.amzn1.x86_64
    kernel-devel-4.4.23-31.54.amzn1.x86_64
    kernel-tools-4.4.23-31.54.amzn1.x86_64
    perf-4.4.23-31.54.amzn1.x86_64
    kernel-debuginfo-4.4.23-31.54.amzn1.x86_64
    kernel-headers-4.4.23-31.54.amzn1.x86_64
    kernel-debuginfo-common-x86_64-4.4.23-31.54.amzn1.x86_64